TIN Matching Delays

Incident Report for RMIS

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 07:24 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 23, 2026 - 08:34 PDT

Investigating

We are currently experiencing IRS TIN matching delays. We are working to resolve as quickly as possible.
Posted Jun 19, 2026 - 07:17 PDT
This incident affected: IRS TIN Matching.